Chapter 2. Requirements

Table of Contents

2.1. User interface
2.2. Workers

2.1. User interface

PoD UI/Server/WN run on Linux and Mac OS X.

General requirements:

  • Incoming connection on pod-agent's port (configurable)
  • ROOT 5.25.04 or higher (xrootd enabled)
  • BOOST 1.33.1 or higher (to use pod-remote(1), BOOST 1.41.0 or higher is required)
  • cmake 2.6.2 or higher
  • shell: BASH

Additional requirements for gLite plug-in:

  • gLite UI 3.2
  • gLite WMS (WMProxy endpoint)

Additional requirements for SSH plug-in:

  • A public key access (or password less, via ssh-agend, for example) to destination worker nodes.

2.2. Workers

General requirements:

  • Outgoing connection for a port range (configurable). This is needed by pod-agent worker to be able to connect to PoD server
  • ROOT 5.25.04 or higher (xrootd enabled). A ROOT installation on worker nodes is not strictly required, but is recommended. If available, it will significantly speed up the start up time of the PoD workers. If there is no ROOT on WNs, PoD will download and use its default ROOT version for every worker node, which can increase the start up time of the workers and the network traffic.
  • shell: BASH

Additional requirements for gLite plug-in:

  • gLite WNs (at least v3.0)